Node.js action outage
Incident Report for Convex
Resolved
At this point, we are confident actions are stable and fully operational.

Total degraded time was approximately ~90 minutes, from 12:00 PDT to 13:30 PDT.
Posted Jun 13, 2023 - 22:36 UTC
Monitoring
Actions appear to be running successfully again, but we'll wait to completely resolve this incident until AWS clears its own lambda incident.
Posted Jun 13, 2023 - 21:12 UTC
Update
Updating issue state to better reflect severity of impact on Convex.
Posted Jun 13, 2023 - 21:08 UTC
Identified
We're continuing to keep an eye on AWS lambda status and we'll ensure Convex has fully recovered when the downstream incident is cleared. Thanks for your patience.
Posted Jun 13, 2023 - 20:24 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 13, 2023 - 19:36 UTC
Identified
AWS Lambda has an outage https://health.aws.amazon.com/health/status so Convex actions which utilize the Node.js runtime may currently experience increased error rates.
Posted Jun 13, 2023 - 19:32 UTC
This incident affected: Live Traffic (Node.js Runtime).