Elevated latency for function calls for some deployments

Incident Report for Convex

Resolved

This incident has been resolved.
Posted May 06, 2026 - 18:24 UTC

Monitoring

A fix has been implemented and we are monitoring the results
Posted May 06, 2026 - 18:04 UTC

Investigating

Convex on-call engineers are investigated elevated latency for function calls on a small set of Convex deployments
Posted May 06, 2026 - 17:43 UTC
This incident affected: Live Traffic (Free & Starter, Professional).