Custom domain creation encountering errors

Incident Report for Convex

Resolved

This incident has been resolved.
Posted May 26, 2026 - 18:55 UTC

Identified

We’ve identified an issue causing newly configured custom domains to remain in the pending verification state. Existing custom domains continue to function normally.

We’re working with our upstream provider to resolve the issue and will provide updates as we have more information.
Posted May 26, 2026 - 17:48 UTC
This incident affected: Development Services (Professional, Business).