Convex Service Interruption
Incident Report for Convex
Postmortem

At 2024-04-17 00:45 UTC, during routine maintenance, a configuration change was made that temporarily removed access to a secret that Convex function running services depend upon for operation.

The Convex engineering team identified and fixed this configuration change within 11 minutes, restoring services at 00:56 UTC.

Posted Apr 17, 2024 - 01:06 UTC

Resolved
This incident has been resolved. More details coming soon in a postmortem.
Posted Apr 17, 2024 - 00:56 UTC
Investigating
We are currently investigating this issue.
Posted Apr 17, 2024 - 00:45 UTC
This incident affected: Live Traffic (Node.js Runtime, Database Services, Function Runtime) and Development Services (Authoring APIs, Dashboard, Documentation Portal).