Text and vector search unavailable for some deployments

Incident Report for Convex

Resolved

This incident has been resolved.
Posted Jan 17, 2026 - 02:03 UTC

Monitoring

The issue has been mitigated and we are rolling out a permanent fix.
Posted Jan 17, 2026 - 01:05 UTC

Investigating

Text and vector search queries are failing for some deployments
Posted Jan 17, 2026 - 00:09 UTC
This incident affected: Live Traffic (Node.js Runtime, Database Services, Function Runtime).