elevated latency for a small subset of convex deployments

Incident Report for Convex

Postmortem

We had elevated latencies on a single database that required us to temporarily shed load while resizing and reparenting the db. This lead to a period of elevated latencies for all instances on that database followed by downtime for a smaller subset of instances while we performed the maintenance operation. This issue should not occur under normal circumstances and was due an underlying database problem that required manual intervention to resolve. We apologize for the impact to those impacted!

Posted Mar 25, 2026 - 19:50 UTC

Resolved

This incident has been resolved.
Posted Mar 25, 2026 - 19:46 UTC

Identified

A small subset of free instances are experiencing availability issues while we restore service.
Posted Mar 25, 2026 - 17:54 UTC

Investigating

We're investigating elevated latency for functions on a subset of Convex deployments
Posted Mar 25, 2026 - 16:27 UTC