some customers hitting OptimisticConcurrencyControlFailure on code pushes

Incident Report for Convex

Resolved

This incident has been resolved.
Posted Jan 29, 2026 - 01:09 UTC

Identified

We've identified a fix and are rolling it out to a subset of customers before deploying more widely
Posted Jan 28, 2026 - 22:51 UTC

Investigating

Some customers are currently unable to push new code without hitting an OptimisticConcurrencyControlFailure error. We're investigating and working on resolving.
Posted Jan 28, 2026 - 22:40 UTC
This incident affected: Development Services (Authoring APIs).