Availability issues across all Convex deployments

Incident Report for Convex

Resolved

We had approximately 10 minutes of availability impact caused by a cascading failure after performing a configuration change to migrate a database cluster. We apologize for the impact and will be refining these processes to avoid this happening again.
Posted Jun 23, 2026 - 18:18 UTC

Update

We believe the issue to be resolved, currently monitoring.
Posted Jun 23, 2026 - 18:15 UTC

Investigating

We're currently investigating an availability issue affecting Convex deployments and will provide an update in the near future.
Posted Jun 23, 2026 - 18:13 UTC
This incident affected: Live Traffic (Free & Starter, Professional, Business).