Code Deployment Degraded

Incident Report for Convex

Resolved

This incident has been resolved.
Posted Nov 15, 2025 - 00:42 UTC

Monitoring

We have deployed a fix and error rates are falling.
Posted Nov 14, 2025 - 23:05 UTC

Update

We are continuing to investigate this issue.
Posted Nov 14, 2025 - 21:29 UTC

Investigating

Some calls to AWS to deploy new versions of customer code are failing. Provisioning new preview deployments is also impacted.

Live production traffic is unaffected.
Posted Nov 14, 2025 - 21:29 UTC
This incident affected: Development Services (Authoring APIs).